Jump to content

Recommended Posts

Posted (edited)

So I bought the controller in June, arrived somewhere around September (last week or 2 weeks ago), worked fine for the first couple of days.

I went and tried playing Call of Duty Modern Warfare, turned on Rapid Fire, worked for a bit, connected the controller to my computer using a USB cable, Rapid Fire doesn't turn on now.

If I do send back the controller, is it going to take months for me to get it back again? (I haven't tried factory reset yet, saw a similar post, will try it tomorrow)

 

ALL other mods work (that I've tried). Rapid Fire is the only one that doesn't activate/turn the LED red.

Mods I tried:
Akimbo, Rapid Trigger, Fast Reload, Jitter, Sniper Breath, Quickscope

Edited by benjamin slick jr

Share this post


Link to post
Share on other sites

Hi Ben, 

From what you've described, it looks like there is a bug in the modchip. Please request RMA in your account to send the controller back for inspection and repairs/replacement. Returns are fast, they are handled by a a separate department, as long we have the controller back before the week end, it will be inspected, fixed and sent back to you before the following Monday. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...